Epson Perfection 2480 scanner..

I can’t believe that this was so easy to get working under Dapper.

Open up a terminal & type..

sudo mkdir /usr/share/sane/snapscan/

My copy of the Firmware can be found here! (not sure if this is legal or not?) Save it to your Desktop & In the terminal type..

cd Desktop

sudo mv esfw41.bin /usr/share/sane/snapscan/

sudo gedit /etc/sane.d/snapscan.conf & change the line that reads..

firmware /usr/share/sane/snapscan/your-firmwarefile.bin & change /your-firmwarefile.bin to /esfw41.bin & save your changes before exiting.
That’s it! just plug in your scanner & start XSane or the Gimp.

I’ve not done a full test yet, but I’ve scanned in the XSane program & the Gimp without any hassle.

Advertisements

16 thoughts on “Epson Perfection 2480 scanner..

  1. Glad to be of help πŸ˜€
    Just out of interest.. you had to use the esfw52.bin to get the Epson Perfection 2480 scanner to work, or was it another model of scanner?

  2. Just installed Fedora core 5 with latest yum updates. Your instrunctions worked fine. Your esfw41.bin and my Epson 2480 worked together well.

  3. Cheers Drakazz.
    Funny you should say that as I’ve just remembered that I never listed it with the search engines. Done it now though so it should be easier to find from now on πŸ™‚

  4. Right on. I found this website first thing so it took me less time to set up the scanner in Linux than in Windows and it works a treat in Ubuntu. Thanks for posting this and thank god it’s still up after 2 years!

  5. thanks a lot for this resource!
    but i have a little problem. when i try to scan with my epson 2480 on debian a pop-up appears…
    Failed to open device ‘snapscan:libusb:005:005’
    Invalid argument

    can someone help me to fix this?

  6. but it doesnt work for cx5500?what do i do for this?im a dentist and the terminal things taking me to the edge so please guide me like ud guide a fool πŸ™‚

  7. thank you!!!

    I spent lot of time trying to get my scanner working and finally, following these simple steps, sane is functioning fine!
    I have a Agfa Snapscan e52 on an Ubuntu 10.4 machine and got stuck with the error message “Failed to open device β€˜snapscan:libusb:002:002β€²
    Invalid argument”.
    I downloaded the windows driver package (2.0.0.9-e52.exe) and found the needed file (Snape52.bin) under the directory Drivers.
    Now the problem is fixed πŸ™‚

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s